Home > Computers > Fix UEFI BIOS boot problems on a new motherboard

Fix UEFI BIOS boot problems on a new motherboard

November 12th, 2015

Grumpy BIOSYou know the drill: You get a new motherboard. You upgrade. And then the fun begins!

Sometimes, one device or another in your system is not detected properly. Other times, you can’t boot into Windows.

You may even find that you can’t even get into the BIOS after the initial setup… Instead, you are met with a blank screen with a blinking white cursor, and pressing Del or F2 does nothing!

In some cases, these problems can indicate a defective motherboard or other component. But before you go RMA-ing anything, try changing the following settings in your UEFI BIOS…

So, the first thing you’re gonna need to do is get into the BIOS. If you can’t get in because you see a blank screen instead of a “boot logo” during the BIOS POST (power on self test), you’ll need to:

  1. Turn off the puter
  2. Unplug the puter
  3. Pop out the little battery on the motherboard
  4. Usually, you’ll want to stick a jumper across the 2 pins on the motherboard labeled CLRTC (or something similar) for a few seconds
  5. Put everything back together, and boot. Voila! You’re back into the BIOS.

Right. Now that you’re in the BIOS, you’ll need to check a few things. Note that the following screenshots are for the UEFI BIOS in an ASUS Z170-A motherboard. This motherboard uses Intel’s new Z170 chipset, which is only a few months old.

If you find yourself with a similar very new motherboard, the absolute first thing you should do is update the BIOS. Especially with newer chipsets and motherboard, there will be many bugfixes released in the form of a BIOS update. Contrary to what most people will tell you, I’m telling you that in most cases, UPDATE YOUR BIOS.

I do this whole puter-building thing a lot, and I’ve been doing it for a long time. When you get a new motherboard, why wouldn’t you update the BIOS? With each BIOS release, the accompanying note is usually something like, “Improves system stability”, or “Improves compatibility with USB devices”. It’s a no-brainer!

The method of updating your BIOS varies by manufacturer, and you can find instructions in your motherboard manual. But usually, you just have to:

  1. Download and extract the BIOS update file from your mobo manufacturer’s web site
  2. Copy the extracted BIOS file to a USB stick
  3. Reboot
  4. Use the built-in utility in the BIOS to flash (or update) the BIOS to the newer version. For example, on Asus motherboard, the built-in BIOS update utility is called EZFlash. It’s really easy, as the  name implies.

Flashing your BIOS will usually erase all your BIOS configuration settings, so remember what they are!

Moving along to how to fix all your New Motherboard Problems…

Again, the following screenshots and instructions are specifically for an ASUS Z170-A motherboard, so your BIOS may vary. But, it’s pretty much guaranteed that your BIOS settings will be very similar.

First, get into your BIOS. You’ll prolly want to go the Boot settings, like so:

UEFI Boot Screen

Notice that I have disabled Fast Boot and DirectKey, as well as Option ROM Messages.

On this particular motherboard, Fast Boot does very little to speed up the boot time if you configure everything else correctly. DirectKey is useless since there is no button to use on the case for this particular puter. DirectKey is a feature that lets you have a “reset button” that takes you directly into the BIOS. Option ROM Messages is kind of pointless – and slows down your boot time – unless you have an add-in card that needs to run its own sort of BIOS initialization mojo. You would also turn the Option ROM Messages on if, say, you wanted to enable your ethernet ROM in order to boot over the network… that sort of thing.

Next, on the same screen, scroll down, and you’ll see this:

UEFI Boot Screen - scrolled down

Here we get to the really important part! Click on CSM (Compatibility Support Module). You’ll see something like this:

UEFI CSM Settings

Now, you might think that you can set Launch CSM to Enabled, and then futz with each of the four settings underneath it. On this board, these were the default settings – although I have no idea why. I highly recommend that you do NOT do this – unless you really know what you’re doing. Set Launch CSM to Auto, like so:

UEFI CSM Auto is GOOD!

Why? Well, on this particular mobo, I had great difficulty getting Windows to boot. It also wouldn’t let me into the BIOS on reboot (I got the blank screen with a blinking cursor). Furthermore, when I did finally manage to get Windows to boot, I was greeted with this Windows load screen:

Oh look, Windows 10 is Vista!

WTH?!  That’s not the pretty Windows 10 boot screen. It’s like a Vista flashback! EEK!

I concluded from this problem that Windows 10 was having great difficulty with some BIOS setting, and it was pretty easy to conclude that it was the CSM settings. CSM is a feature of UEFI BIOSes where the mobo will  (hopefully automatically) detect whether it should use “legacy BIOS” or “new UEFI” features for setting up your puter and launching the OS.

Hence, my recommendation to set Launch CSM = Auto. That fixed darn near all my problems with this particular Z170-based machine!

Finally, back on the main Boot screen, you’ll want to click on Secure Boot (see above image). Doing so will give you something like this:

UEFI Secure Boot

This is all about the whole Microsoft Secure Boot initiative. If you don’t want to use all this new-fangled weirdness, just set the OS Type to Other OS. Boom, done.

Now save your settings and reboot, and you should be all set. Well, don’t forget to set the proper OS drive as your 1st boot device. That’s kind of important…

Finally, note that with newer motherboards, you sometimes have to attach your USB keyboard and mouse to USB 3 ports. Yeah, it’s crazy, but that’s what happens when USB 2 ports start disappearing from the back of new motherboards!

Have fun – and above all, try not to throw your new puter out the window when it won’t boot! 😉

Computers , , , ,

Shortlink:

  1. Giovanni
    February 7th, 2016 at 19:04 | #1

    I had another Z170 Asus mobo at hand, and cannot find the ‘Secure boot’ menu, no way! I thought it was crazy, maybe the ‘Launch CSM = Auto’ wasn’t set that day… ? Is it always shown on the ‘Boot’ menu?

    Then I’ve flashed the new bios – the mobo restarted like 4 times and that was odd – but no ‘Sucure boot’ anyway. ? That was eventually to reset the Secure Keys from a previous UEFI installation as I was used to do on certain Win8 laptops.

    • February 7th, 2016 at 19:14 | #2

      Maybe some of the Z170 mobos don’t have the secure boot stuff? I only worked with a Z170-A so far…

  2. Giovanni
    February 8th, 2016 at 01:26 | #3

    Here it was, a Z170-K. Should be about the same. I’ll keep that screenshot of yours at hand when I’ll get another chance 🙂 Thanks!

  3. wayloncovil
    March 19th, 2016 at 03:20 | #4

    Hoping you can help. I received my h170 pro gaming motherboard this week.
    I installed windows 10 from my usb drive. When the bios was asking me which to boot (there were two options) UEFI or just the regular flash disk, I chose the one without UEFI. The usb drive booted and I installed windows on my SSD.
    Today I installed a new hard drive. Windows would not boot.
    I took out all the hard drives in my computer except the SSD and it still won’t boot.
    I followed your recommendations above and it still won’t boot.
    I see two devices in the computer. Hard Drive and Samsung EVO 850. I had previously selected the generic hard drive and it would boot into Windows. Now, neither option works. I have the most recent bios on this board. Are there any other suggestions you have?
    Thanks!

  4. wayloncovil
    March 19th, 2016 at 03:44 | #5

    Have an update to this. I booted into my Windows USB Drive and found the option that lets me fix issues when Windows doesn’t boot option.
    That seemed to fix the problem.
    Any thoughts on what happened?
    Thanks!

    • March 19th, 2016 at 13:56 | #6

      Hmm, I’m not entirely sure, but I guess maybe Windows went a little bonkers and something got screwed up. That did happen to me once when I was switching between UEFI and Legacy boot modes. But I fixed it exactly as you did! One of the “Windows won’t boot” repair tests is to check the bootloader and repair it if need be.

  5. Soham
    March 26th, 2016 at 23:21 | #7

    I suggest you keep it on UEFI and legacy OPROM and change the rest of them to UEFI only. As UEFI incorporates Legacy BIOS also , but in a more refined and efficient manner. I changed mine to my suggested setting and it is working just fine.

  6. Ron
    April 13th, 2016 at 22:36 | #9

    Thank you, thank you, thank you for CSM Auto.

  7. grateful
    May 14th, 2016 at 17:05 | #10

    Omg you solved my problem. Thanks!
    It kept giving me a bios bootloop after windows update and/or printer installation.

  8. Weldon
    August 1st, 2016 at 02:38 | #11

    I have a asus h170 refuses to load any os no matter what I tried. Geek squad says just buy a non asus product.

  9. Gregory Pierce
    August 25th, 2016 at 02:31 | #12

    Was having a similar issue and came across this website. My issue ended up having nothing to do with any of this, however. In the BIOS upgrades, Asus set the actual SATA configuration on my board to SATA Express instead of M2 which is what my drive was. So no matter what settings I tried, it would never EVER be able to boot. Once I finally caught this, I was able to get the most recent Z170-AR to run with bios 1902 and boot back into Windows 10.

    • August 25th, 2016 at 08:10 | #13

      For some reason, that setting is actually backwards on some Asus Z170 boards with certain BIOS revisions. If you have an M2, it should be SATA Express. If you have SATA, it should be M2. Confused the heck out of me – and many others based on what I read in their support forum!

  10. riki
    October 1st, 2016 at 04:38 | #14

    i have a aegis ii asus and this doesnt work

  11. Brent
    October 6th, 2016 at 20:33 | #15

    This guide is very helpful for Ubuntu as well. Was having trouble with booting. Ubuntu will come up with a “Try Ubuntu” or “Install Ubuntu.” Make sure you try it first! You can install it shortly after.

    Hopefully this will relieve headaches for the Ubuntu crowd.

    Oh and obviously selected “Other OS” in BIOS.

  12. Ryan
    October 14th, 2016 at 04:09 | #16

    Scottie,

    I’m stumped with this one, maybe you can help…I just built a computer with an Asus Z170-A board and have a strange issue where I need to reset the cmos after every full shutdown. Don’t have to remove the battery, just need to short the CLRTC pins and it will boot, but the next time I shut down all the way, have to repeat the process. Thought it might be related to the power/reset switch pins, but tried those every which way as well as leaving them unplugged, no luck. Nothing overclocked, no GPU installed, tried with no SATA drives connected. Any thoughts?

    • October 14th, 2016 at 11:06 | #17

      Ah yes, this happened to me before with a different motherboard… First thing I’d check though is the DirectKey thing. That’s the header to boot directly into the BIOS by pushing a physical button. Even if you have a button connected, disable DirectKey in the BIOS and see if that helps. I tried to use it, and it seemed to screw things up sometimes when booting or using the DirectKey button (which only worked maybe 20% of the time).

      Then I’d try flashing the BIOS to the latest version. If you have already done that after you got it, then I’d prolly also replace the battery on the mobo, and then reflash just to be sure. I usually unplug, remove battery, and then jumper the CLRTC pins for 5 seconds just to be uber-sure it’s cleared. Then install new battery. Anyway, I’m pretty sure this is what I did with the other mobo that had the same symptoms… It was awhile ago!

      If that doesn’t do it, I would RMA it.

  13. Peter ledwith
    October 15th, 2016 at 23:07 | #18

    Well…..im not impressed with asus. My asus p97iplus with a i5 processor keeps booting straight to the bios screen. Ive tried everything. Messed with every bios setting, flashed the bios and reset cmos. Nothing works. Ive reseated the cpu…tried reseating the memory dimm. Used different hard drives. It detects my hard drives and external usb dvd drive but wont get to a boot screen. It wont let me get to a boot menu. Looks like a common issue. I thought asus were a quality brand!

    It gets to the post screen……goes black with a flashy cursor on the top left corner for a split second. Then 2 green bands flash at the bottom of the screen and it goes to the bios.

    Any ideas? Im worried it may be my cpu. Dont want to buy another motherboard to find the same issue.

    • October 16th, 2016 at 00:58 | #19

      Well, I’ve never had a bad CPU… I’m starting to think myself that Asus quality is dropping. I’m stumped!

  14. Peter ledwith
    October 15th, 2016 at 23:10 | #20

    @Scottie
    I dont have a direct key setting on my board…..

  15. Peter ledwith
    October 16th, 2016 at 11:13 | #21

    Concidering these things arnt cheap…..its not good. I would have thought reinstalling the firmware would have solved it but nope. There are far too many settings on these motherboards. Reseting to default should work but it doesnt. Why should i have to mess with keys and stuff just to get it to boot a hard drive? There must be a fault. Guess il have to buy another mb. Not asus this time though.

    • October 16th, 2016 at 12:37 | #22

      I usually go for midrange motherboards. Deluxe and Pro and Gamer ones are always so loaded with features, they tend to be a pain to set up. The cheapest models are usually too cheap, if you know what I mean. I really hope this isn’t a new general downwards trend… I’ve sworn by Asus mobos for about 17 years now, and only ever had 1 defective one that I had to exchange out of maybe 100 systems. I did once deal with a P5KC that supported DDR2 and DDR3. That was a pain because even the DDR2 slots were VERY picky about the RAM they would work with. It refused to boot otherwise, or even show the BIOS setup. SIGH. Well, my next motherboard might not be Asus, either!

  16. Matthew Collins
    December 1st, 2016 at 09:40 | #23

    The Asus Z170M-Plus motherboard just sucks.

    It literally blew 2 DVD drives and 2 Sata HDD and I mean fried them when I turned on the comp.

    Finally when I did manage to get a DVD drive to not blow out from being fried, it didn’t read anything I put in the drive. The system Read the drive but the drive itself wouldn’t read anything.

    The DVD drive works fine when I hook it up to another computer so it’s not the drive.

    I then had to format my SSD on another computer and when I put it through this motherboard it gets to the logo screen then blue screens.

    There is no setting and or combination of settings that will allow the SSD to boot an OS on this motherboard.

    The SSD works perfectly fine in any other computer I put it in, in fact I’m typing this messages from a computer that has it in it. So the problem is the board itself. It just doesn’t do what a board is supposed to be doing.

    This board is nothing but trash.

    • December 1st, 2016 at 13:53 | #24

      I dunno, but that sounds like a bad board to me. I’d RMA it to the place you bought it, or to Asus directly if necessary. That’s just not normal. The SSD not being recognized can be specific to the mobo (even if it’s not defective). I had that problem with an older Asus 4000-series Intel mobo, coupled with an OCZ SSD. Half the time, the mobo wouldn’t see the SSD. Put a Samsung EVO 840 in, and it’s worked fine ever since. So, it could be a compatibility thing, but the DVD drive explosion thing tells me something else is going on, and it’s not good!

  17. December 21st, 2016 at 16:27 | #25

    didn’t work for me though 🙁

  18. John White
    December 22nd, 2016 at 19:53 | #26

    Zoostorm ready made PC. Asus A68HM plus with AMD A8 7600 cpu. Couldn’t even install Windows 7. These changes worked for me. Many thanks.

  19. Aaron
    January 3rd, 2017 at 05:20 | #27

    It worked! You are awesome! Thank you so much!

  20. Mark
    January 10th, 2017 at 08:40 | #28

    Hello Scottie and fellow tech denizens,

    Lately I have been tackling with a new build and I swear I have never had as many headaches as I have had with this one. The Z170 chipset has been an utter nightmare. Sigh. Anywho…

    I bought an EVGA z170 Classified K (after reading that Asus has dropped a bit in quality since the previous refresh, mistake maybe?) and I believe I have pinned down some funkiness with the UEFI bios settings that Windows and my drives have trouble with. I use a Samsung EVO 850 Pro and older model Intel SSD Elm Crest 510 series drive. With UEFI settings, it continuously boots to safe mode and will not allow me to boot to either drive’s OSes. If I go into SATA settings, I can see them there but I can’t boot to them even by forcing.

    Now, if I set bios settings to Legacy, (alas this board doesn’t have a CSM auto setting like your example board) I can boot to those drives. However, about half the time I still need to force it to boot to the Samsung drive to start Windows 10 (Intel is my Windows 7 installation).

    I haven’t tried switching to the secondary BIOS by flicking the switch the Classified K has, though. But, I am not certain this would make booting any easier. Is there something I am missing here? I have already RMA’d one board because it came DOA. So yeah, frustrated. Any thoughts are truly appreciated!

    • January 10th, 2017 at 12:51 | #29

      Oh man… I feel your pain. 😉 I have seen other boards where futzing with the Legacy/UEFI boot settings helped. But sometimes, motherboards just simply do not work with certain SSDs. Even when the manufacturer tells you that SSD is certified for use with the board, it still might not work. I really don’t know what the deal is at a low level, but it’s pretty annoying. I even had one motherboard that had boot drive problems until I put in a precise combination of RAM modules (sizes and brands), and then it worked fine for 4 years. ??? I wish I had more useful advice than that, but alas…

  21. Mark
    January 11th, 2017 at 00:46 | #30

    @Scottie

    No worries, Scottie! I got very bothered and looked more into the nature of UEFI (it’s come as new thing to me because I’ve built PCs for sometime on plain old BIOS for many years).

    What I have discovered is this, although I am on the verge of testing it out for myself is that:

    UEFI does not play nice with drives partiioned/setup to use MBR, because MBR is based off of old LEGACY/BIOS technology. What happens when you have partitions setup with MBR instead of GPT (UEFI)with UEFI settings on is that UEFI will not recognize those drives as valid bootable drives, even if the system does see them hooked up. In my case, both of my drives are using MBR and not set up to GPT.

    What I am going to test is just this. Because my motherboard only allows you to use LEGACY or UEFI (one or the other but not both with CSM), I will reformat a drive to GPT, install Windows 10, and then see how it plays out. My guess is that this is the issue and not the board. One can hope, at least!

    I will write back once I have tested this because it may be something you may update your guide with, as it would be very useful for people having issues like myself. 🙂

    • January 11th, 2017 at 12:04 | #31

      Yeah, that’s the ticket. It’s totally possible the GPT thing will work. It would be kind of surprising though, because that would mean the Legacy mode of the motherboard is not very “legacy-ish”. Well, let me know what happens!

  22. Mark
    January 15th, 2017 at 09:30 | #32

    @Scottie

    Good news!

    So, it turned out that my hypothesis was correct. UEFI may often not play nice with drives that are partitioned with MBR using traditional Bios. As a result, if you have a motherboard that does not have CSM and only allows you one or the other (Legacy Bios or UEFI), you will have a hell of a time trying to boot to a drive, if you can at all.

    For motherboards that do not have CSM, (most likely any new EVGA boards like Z170 and the new z270 lines)it is recommended that you reformat them using the “Diskpart” utility in an elevated (Administrator mode) Command Prompt and partitioning/converting to GPT.

    A Technet article has those instructions and the important snippet is below:

    “To change a master boot record disk into a GUID partition table disk using a command line

    Back up or move the data on the basic master boot record (MBR) disk you want to convert into a GUID partition table (GPT) disk.

    Open an elevated command prompt (right-click Command Prompt, and then click Run as Administrator) and type diskpart. If the disk does not contain any partitions or volumes, skip to step 6.

    At the DISKPART prompt, type list disk. Make note of the disk number you want to convert.

    At the DISKPART prompt, type select disk .

    At the DISKPART prompt, type clean.
    ImportantImportant
    Running the clean command will delete all partitions or volumes on the disk.

    At the DISKPART prompt, type convert gpt.”

    Phew! Anywho, apologies as it too me a few days to have the spare time to test this. I hope this is useful information you can use to update your article on this, Scottie! That said, thank you for providing this resource, Scottie. Even though it didn’t diagnose my specific issue, it helped orient me towards getting this figured out! Much respect and much appreciated! 😀

    • January 15th, 2017 at 11:52 | #33

      Awesome!! Thanks for the info, and I’m glad you got it sorted. Good to know about the CSM thing, also. I guess next time I upgrade my motherboard, I may be converting my boot drive to GPT… 😉

  23. Mark
    January 16th, 2017 at 07:45 | #34

    @Scottie

    Glad to add my findings! At first I was iffy on UEFI but it really did half my boot time. It basically boots straight to the OS from the Bios splash screen, assuming you don’t interrupt it by entering Bios proper. Pretty neat! By the way, installing Win 10 fresh will automatically convert it to GPT when you format it in the setup screen. 😉

    • January 16th, 2017 at 13:15 | #35

      Interestingly enough, I just updated my Asus Z170-based motherboard to the latest BIOS revision. Before, I had a brief Win 10 boot screen with the loading indicator. Now with the updated BIOS, I noticed it does the same as you mentioned: BIOS splash -> Win 10 login screen. That’s with an MBR boot drive and CSM thing set to auto. Update BIOS, get faster bootup… So, I guess this UEFI thing is pretty sassy after all!

  1. No trackbacks yet.